Eric's Technical Outlet

Learning the hard way so you don't have to

Dell OpenManage Server Administrator 7.1 on Server Core or Hyper-V

Dell has done something to the installer for the recent version of OpenManage Server Administrator so that it doesn’t work on Server Core, which includes native installations of Hyper-V.

Symptoms

  1. Running “X:\windows\PreReqChecker\RunPreReqChecks.exe /s” errors out with “omchecks has stopped working”
  2. The installer (accessed by running “msiexec /i X:\windows\SystemsManagement\SysMgmt.msi” stops with the error “Failed to load OMIL library”

Solution

Install OpenManage Server Administrator 6.5 first (the command on that CD is “msiexec /i X:\SYSMGMT\srvadmin\windows\SystemsManagement”). As soon as that installer finishes, you’ll be able to install 7.1 without error. If you haven’t got the older installation media, you can download it from Dell’s site. If your particular server is too new to have 6.5 available, check the download list for earlier servers, such as the PowerEdge R515.

You do not need to perform any cleanup on 6.5 as 7.1 replaces it very cleanly.

Additional Information

I’ve had some strange and not always reproducible problems installing other Dell update packages, usually drivers, on Server Core and Hyper-V whenever OMSA is not installed or is out-of-date. The one I remember most clearly was related to the Lifecycle Controller.

Advertisements

7 responses to “Dell OpenManage Server Administrator 7.1 on Server Core or Hyper-V

  1. Samuel November 2, 2012 at 10:40 am

    from where can I download the 6.5?

    Like

    • Eric Siron November 2, 2012 at 10:55 am

      http://www.dell.com/support/drivers/us/en/RC810590/DriverDetails?driverId=G2WT6

      Like

      • Samuel November 6, 2012 at 9:25 am

        tks

        Like

  2. James October 24, 2012 at 10:56 am

    Thank you! I’ve installed OM on several other Servers and couldn’t get it to work on this box. After I installed 6.5 it worked great and was able to upgrade to 7.1 without any trouble. Thanks for the info!

    Like

  3. Alex September 26, 2012 at 6:09 am

    Thanks. Same problem here.

    Like

  4. Pingback: Brian Reid | C7 Solutions: Installing Dell Open Manage 7.1 on Hyper-V R2 Servers « JC’s Blog-O-Gibberish

  5. Brian Reid August 21, 2012 at 7:46 am

    Excellent – just what I was looking for the other week and could not solve. Found this and its a timely find.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: